您的位置:  首页 » 量化交易与机器学习 » backtrader » 安装 – backtrader中文教程

Installation

Requirements和versions

backtrader是自包含的,没有外部依赖(除非你要绘制)

基本要求是:

  • Python的2.7
  • 蟒3.2 / 3.3 / 3.4 / 3.5
  • pypy / pypy3

附加要求,如果标绘希望:

  • <>8<>

    这可能与以前的版本,但用于此的一个development

NOTE:在撰写Matplotlib的时间不得低于pypy/pypy3

的Python 2.x的/ 3.X compatibility

发展需要Python 2.7版下,有时在3.4的地方。测试运行当地既versions.

用3.2 / 3.3 / 3.5和pypy / pyp3兼容性与连续检查使用PIP Travis

Install下整合来自pypi

For例如:

pip install backtrader

easy_install用同样的语法也可以从PyPI将是applied

Install(包括matplotlib

如果绘图能力都希望`使用此:

pip install backtrader[plotting]

这拉动matplotlib这将在其他dependencies.

Again反过来拉你可能更喜欢(或只能访问…)easy_install

从source

First`安装下载版本或者从GitHub的站点获得最新的压缩包:

  • 的https://github.com/mementum/backtrader

And拆箱之后运行命令:

python setup.py install

在从源运行的project

Download释放或从GitHub的站点获得最新的压缩包:

  • 的https://github.com/mementum/backtrader

And然后复制backtrader包目录到自己的项目。下例如Unix类操作系统:

tar xzf backtrader.tgz
cd backtrader
cp -r backtrader project_directory

请记住,你会那么需要手动安装matplotlib为plotting.

发表评论

电子邮件地址不会被公开。 必填项已用*标注