You are here:  Home » PHP » 如何在WordPress中为主要版本启用自动更新

WordPress最近发布了其最新版本3.7。它有一些重要的改进,但自动更新绝对是此版本的最重要的功能。现在,当有新的次要版本或安全版本可用时,WordPress可以自动更新。之前,我们向您展示了如何在WordPress中禁用自动更新。但如果您真的喜欢自动更新的想法,那么您实际上也可以为主要版本启用它。在本文中,我们将向您展示如何在WordPress中为主要版本启用自动更新。

WordPress 3.7中的自动更新仅在存在次要或安全版本时运行。例如,运行3.7的典型WordPress网站将在没有任何用户输入的情况下自动更新为3.7.1,但它不会更新为3.8,这将是一个主要版本。

对于运行许多WordPress站点而没有任何托管WordPress托管的用户,更新所有WordPress站点可能非常耗时。

为主要WordPress版本启用自动更新

核心团队未启用所有WordPress版本的自动更新,因为通常主要版本会发生重大更改。这意味着有时您的网站可能没有准备好立即更新,如果它有很多自定义。但是,如果您对自己的WordPress托管服务提供商,网站的插件和主题充满信心,那么您也可以为主要版本启用自动更新。

只需在您网站的 wp-config.php 文件中添加这一行代码即可。

define( "WP_AUTO_UPDATE_CORE", true );

代码有一个小问题。它还可以进行开发或夜间更新。要禁用夜间构建和开发更新,您需要在特定于站点插件或主题的functions.php文件中添加此代码。

add_filter( "allow_dev_auto_core_updates", "__return_false" );

此过滤器将禁用每晚构建或开发更新自动更新

使用此解决方案,只要有新的WordPress版本,您的WordPress网站现在就可以自动更新,无需您的输入。让我们知道您对自动更新的看法?在下面发表评论。

评论被关闭。