You are here:  Home » PHP » 如何在WordPress中禁用插件更新以及为什么不应该这样做

最近,我们的一位读者询问是否可以在WordPress禁用插件更新?可以在WordPress中禁用插件更新,但没有充分的理由这样做。在本文中,我们将向您展示如何在WordPress中禁用插件更新。我们还将讨论为什么不应该这样做以及这样做的后果。

How to Disable Plugin Updates in WordPress

为什么你不应该在WordPress中禁用插件更新?

许多WordPress用户认为插件更新可能会破坏他们的网站。如果您使用符合标准的WordPress主题的最佳WordPress插件,那么升级破坏您网站的可能性非常低。

请参阅我们的初学者指南,了解如何为您的网站选择最佳的WordPress插件。对于主题,您可能希望在选择完美的WordPress主题时看到我们应该考虑的9件事清单。

插件更新不仅提供新功能,还可以修补安全漏洞,提高性能,并修复最新或即将推出的WordPress版本的兼容性问题。

通过不更新插件,您有意破坏WordPress网站的安全性和稳定性。

一些开发人员希望禁用客户端站点上的插件更新,以防止他们破坏他们的网站。在大多数情况下,这不是一个好理由,因为大多数客户关系不会永远存在。在这种情况下,您将为您的客户提供一个易受漏洞影响的网站。

我们认为教育您的客户更好。

如果您仍然必须在您的网站上禁用插件更新,那么您将如何做到这一点。

禁用WordPress中的所有插件更新

您需要做的第一件事是安装激活Easy Updates Manager插件。有关更多详细信息,请参阅有关如何安装WordPress插件的分步指南。

激活后,您需要访问 Dashboard»更新选项来管理插件设置。

单击“常规”选项卡,然后向下滚动到“所有插件更新”选项。单击“已禁用”以关闭所有插件更新。

Disable all plugin updates in WordPress

不要忘记单击保存更改按钮来存储您的设置。

选择地禁用WordPress中特定插件的更新

您还可以有选择地禁用某些WordPress插件的更新。这比禁用所有插件更新要好一些。

您需要访问仪表板»更新选项页面并单击“插件”选项卡。在那里,您将看到WordPress网站上所有已安装插件的列表。

Disallow updates for a specific plugin

您只需单击插件下方的“禁止更新”即可禁用该特定插件的更新。

Easy Updates Manager允许您管理所有WordPress更新,包括核心,插件,主题和翻译更新。有关详细说明,请参阅我们的指南,了解如何更好地管理自动WordPress更新。

我们希望本文能帮助您了解如何在WordPress中禁用插件更新以及为什么不应该这样做。您可能还希望看到有关如何使用Adminimize从WordPress管理员隐藏不必要的项目的指南。

评论被关闭。