You are here:  Home » PHP » WordPress 2.8.1正式发布

WordPress 2.8.1正式发布,因为它是由Ryan发布在WordPress博客上的。这个版本有两个测试版和多个补丁,直到它今天终于发布。

WordPress 2.8.1修复了许多错误并提高了插件管理页面安全性。在以前的版本中,某些插件添加的管理页面可以由非特权用户查看,从而导致信息泄露。并非所有插件都容易受到此问题的影响,但WordPress工作人员和WPBeginner建议您升级到2.8.1以确保安全。

在WordPress 2.8.1中进行了大量更改,我们将列出一些突出显示在这里,但如果您愿意,可以看到完整的列表。

  • 某些主题调用get_categories()以使其在2.8中失败。2.8.1可以解决这个问题,因此这些主题不需要改变。
  • Dashboard内存使用量减少了。加载仪表板时,有些人内存不足,导致页面不完整。
  • 从失败的升级中清理时,自动升级不会意外删除文件。
  • 由于压缩问题而未加载富文本编辑器的问题已解决。
  • Extra安全性已经到位,以便更好地保护您免受未进行显式权限检查的插件的影响。
  • 已修复角色名称的翻译。
  • wp_page_menu()默认按用户指定的菜单顺序排序而不是页面标题。
  • 现在可以正确报告上传错误消息。
  • 修复了一些IE用户遇到的自动保存错误。
  • 修复了插件编辑器中的样式故障。
  • SSH2文件系统要求已更新
  • 切换回curl作为默认传输。
  • 更新了转换库以避免mbstring.func_overload出现问题。
  • Stricter内联样式清理。
  • 更严格的菜单安全性。
  • 由于浏览器不兼容而禁用代码突出显示。
  • RTL布局修复。

现在,如果您选择升级我们强烈建议您这样做,您可以通过WordPress现在拥有的单击升级。大多数用户应该已经在他们的wp-admin面板顶部看到一个要求您升级的栏。

评论被关闭。