You are here:  Home » PHP » 您是否应该安装未使用WordPress版本测试的插件?

通常,我们的用户会向我们询问有关插件未使用其WordPress版本进行测试的警告。你应该安装插件插件吗?或者找另一个插件?在本文中,我们将讨论为什么要安装未使用您的WordPress版本测试过的插件?它是什么意思以及如何帮助WordPress社区

当您从WordPress管理区域安装插件时,您可能会看到一个警告,即未使用您的WordPress版本测试插件。

Plugin compatibility warning

WordPress如何获取未经测试的信息

官方WordPress插件存储库是最大的免费和开源WordPress插件集合。提交插件时,作者需要提交带有插件的“自述”文件。然后,插件目录使用此自述文件生成插件页面

自述文件包含“经过测试”标签,用于显示信息。插件作者应该保持这些信息是最新的。

意味着对于每个WordPress版本,插件作者应该测试他们的插件并更新其插件的自述文件。

为什么插件作者不更新此信息?

即使用最新版本测试插件,许多插件作者也根本不更新他们的自述文件。

在理想的世界中,我们希望所有插件作者更新此信息。但我们并不生活在一个理想的世界里。

请记住,这些插件是免费的,您不需要付费下载和使用它们。插件作者不太愿意在每个版本中更新自述文件。他们通常忙于从事全职工作和付费开发项目。

视频教程

订阅WPBeginner

如果您不喜欢该视频或需要更多说明,请继续阅读。

我应该安装这些插件吗?

是的你应该。仅仅因为插件作者没有更新他们的自述文件并不意味着他们没有测试他们的插件或插件不适用于最新版本的WordPress。

如果您在WPBeginner上听说过一个插件,那么您可以放心地假设我们使用最新版本的WordPress测试了该插件。如果您正在查看的文章是最近发布的,那么这意味着该插件与最新版本的WordPress兼容。

另一方面,如果插件未更新超过两年,那么这意味着插件很可能已被放弃。在这种情况下,您不应该安装插件。

值得注意的是,许多尚未更新超过两年的插件实际上仍能很好地工作。但是,您应该自行安装它们。

你可以如何帮助?

您可以在WordPress网站上安装该插件并进行测试。如果它按预期工作,那么回到插件的页面。使用您的WordPress.org用户名和密码登录。接下来,向下滚动到页面底部,您将看到兼容性部分。

Vote for plugin compatability

只需选择您的WordPress版本,插件版本,然后单击Works按钮。通过这样做,你让其他用户知道你已经测试了插件,它按照承诺工作。

您也可以联系插件作者,并请他们更新他们的插件的自述文件

插件坏了怎么办?

再一次,我们想提醒我们的用户,如果它是一个免费的插件,那么插件作者就是按原样提供的。没有保修,甚至没有健全的默示保证。但问题是,如何帮助社区处理破损的插件?

您可以留下建设性且有用的反馈,而不是对插件的支持线程留下严厉的评论。请参阅我们的指南,了解如何正确地请求WordPress支持并获取它。

在做任何事情之前,尝试在不同的实时或本地WordPress安装上安装插件。确保您也能够在其他安装上重现相同的错误。

一旦确定插件已损坏,只需在支持线程中描述错误,并留给插件作者或社区进行响应。如果您没有得到回复,那么您可以尝试联系插件作者。大多数插件作者在其WordPress.org个人资料页面上都有联系信息。

如果这些步骤失败,那么您应该随意访问该插件的页面并投票在兼容性部分下打破插件。

我们希望本文能够帮助您解答有关是否应安装未使用您的WordPress版本测试过的插件的问题。

如果您喜欢这篇文章,请订阅我们的YouTube频道WordPress视频教程。您也可以在Twitter和Google+上找到我们。

评论被关闭。